• HomeBoards
  • RulesRules
  • HelpHelp
  • WikiWiki
  • Donate

Author Topic: Dingoo A330 Help: Doesn't turn on for power or by computer  (Read 3460 times)

DearChaos (OP)

  • Posts: 1
Dingoo A330 Help: Doesn't turn on for power or by computer
« on: September 06, 2013, 09:30:22 pm »
Yo, I need some help.
Just yesterday, I received my new Dingoo A330 running Dingux already. After charging it, I noticed that it wouldn't turn back on so I can use it again. Tried the reset switch a few times and occasionally it would start back up but once it got to the Dingoo Logo, it turned off again...
Later, I connected it to the power and it worked fine when I left it to drink some juice, but as soon as you disconnected it, it turned off again. EVEN THOUGH THE BATTERY HASN'T EVEN DRAINED ITSELF. I plugged it back in, started up an emulator and disconnected it. It didn't turn off this time which was strange.
When I was going to add the rest of the Mega Pack 2.0, I left it chillin' beside me and when I was ready to plug it into the computer, it didn't complain. I searched it and I remember deleting a few apps that didn't show up when I tried looking for them.
After I did that, I started to delete some a Adobe Reader doc. that didn't read either and when I tried to go into one of the folders after that, the computer couldn't read it, and then... it shut off.

Soon after, I couldn't get it to turn on again by computer or by power...

I really don't want to lose this thing otherwise I spent $65 for nothing...
You can call me, the Zombie King, but only if you can survive to call me that.


Post a new topic