Author Topic: A Few Problems (NES Mostly)  (Read 2867 times)

newcomer23

  • Guest
A Few Problems (NES Mostly)
« on: August 16, 2010, 02:27:19 pm »
I always hear people rank the natives NES emulator as the best of the native emulators (it's better than SNES and GEN at least), so I am wondering if there is something wrong with my unit or roms.

-The most annoying problem I encounter is a graphic issue when scrolling the screen, there is a line of garbage colors that flashes each time I move up or down in several games (such as Dragon Warrior IV). This might be a minor thing, but it really bothers me, is it the rom or just a common emulator problem?
-My memory is not that great, but I really think the speed on Super Mario Bros. is faster than normal and the sound seems a little different (perhaps because of speed). This is not much of an issue in other games though.
-A crippling problem with save states: When playing Dragon Warrior IV I once had to save state in the middle of a battle. After doing this the game froze, and I could not continue playing off the save state. I had to go back to the last battery save I had, which was about an hour before that battle. This has happened on several occasions and most recently caused me to stop playing when it happened and I realized I would have to go about 2 hours back because I had not hard saved in a while. NOTE -A save state issue also occurred when I was at the last dungeon of Final Fantasy VI GBA where after I made a save state the graphics were messed up and I couldn't read the battle menus and the cart save was corrupted.
-Cobra Triangle won't start and R.C. Pro Am has invisible sprites, this may be my roms (although I am pretty sure I tested them off of the good set before I put them on). I really should try other roms before griping too much on this, but that is a pain for me, because I have to use my brother's computer or transfer from sd card.
-Crystalis: screen shakes when I talk to someone and the same line garbage problem as Dragon Warrior IV

This may be nitpicking but these issues are rather common among my roms and I would like to know if anyone else is experiencing them.
Also annoying is that I can't load two consecutive gb roms without resetting, has this ever been fixed for native?
I have a white unit that has a paw printed on the back (although I bought it just last winter from chinavasion).





eule

  • * Former Staff
  • Posts: 889
Re: A Few Problems (NES Mostly)
« Reply #1 on: August 16, 2010, 02:45:03 pm »
@ NES: Known issue about the speed, do you use (E) or (U) roms? Try the opposite, i think (E) was right speed, or was it (U)? ;D
Can?t help with savestate issues...
You should try Dingux, if you haven?t yet. Most emulators are more polished/varied (e.g. there are 3 NES emulators) and faster (except GBA/NeoGeo).
The GB rom issue is solved i think, use the HK-patched emulators:
http://filetrip.net/f11182-Dingoo-a320-HK-patched-Default-Software-1-0.html (download on the right, i searched a bit ^^)

newcomer23

  • Guest
Re: A Few Problems (NES Mostly)
« Reply #2 on: August 16, 2010, 05:46:11 pm »
Thanks for the advice and the gnuboy fix, it now works with resetting. I haven't been following closely enough, I thought that was still unsolved.

I was using (U) roms, so that is likely the problem there. I replaced R.C. Pro Am and Cobra Triangle and they work now. I'm not sure if the graphic problems stem from that, but I can't be bothered to replace all of my roms right now.

I do have dingux installed but I like to play what I can on native to use the 4gb storage. I was unaware there were good nes emulators though, last I checked (probably a long time ago) I thought I saw that some of the nes emulators lacked sound so I never really looked into them. I probably will move more over to dingux now, I might relegate native to music and gba.
 

 

kspekh

  • Posts: 7
Re: A Few Problems (NES Mostly)
« Reply #3 on: August 16, 2010, 06:37:13 pm »
I'm disappointed with native NES emulator. 'Battle Toads & Double Dragon: The Ultimate Team' is my favorite NES game. It freezes in the same place of stage 5 (robo-manus) every time. But in Dingux it runs perfect with fceu320...

 

Post a new topic