Author Topic: Sleep problem  (Read 1300 times)

sakya (OP)

Sleep problem
« on: November 21, 2016, 08:24:29 pm »
It seems that my GPD Win crashes every time it goes to sleep...
When I close the screen the GPD Win goes to sleep (as set in the power options): if I reopen it in a few minutes all works fine, but if I leave it closed for more time (let's say 5/10 minutes) then I need to press the power button and a normal boot happens.
Anyone else has this problem? Is there a solution?
Many thanks. ;)

Macatron

Re: Sleep problem
« Reply #1 on: November 21, 2016, 08:40:30 pm »
It seems that my GPD Win crashes every time it goes to sleep...
When I close the screen the GPD Win goes to sleep (as set in the power options): if I reopen it in a few minutes all works fine, but if I leave it closed for more time (let's say 5/10 minutes) then I need to press the power button and a normal boot happens.
Anyone else has this problem? Is there a solution?
Many thanks. ;)

It sounds like you have Hibernate Mode enabled. Hope this helps. :)

http://www.windows10update.com/2015/05/windows-10-tutorials-60-how-to-enable-or-disable-hibernate/


zdanee

  • *
  • Posts: 47
Re: Sleep problem
« Reply #2 on: November 21, 2016, 08:42:26 pm »
I have this problem and as far as I know no fixes has been found yet. It goes for sleep, and after a few minutes if I open it, it's at the login screen and all my apps has been closed, and the machine restarted meanwhile. In the events log there is a new record of unexpected reboot. I set the power button to hibernate the machine instead of sleep and so that closing the lid will only turn off the screen for me.
Cube i7 Stylus + GPD Win

Macatron

Re: Sleep problem
« Reply #3 on: November 21, 2016, 09:02:11 pm »
I have this problem and as far as I know no fixes has been found yet. It goes for sleep, and after a few minutes if I open it, it's at the login screen and all my apps has been closed, and the machine restarted meanwhile. In the events log there is a new record of unexpected reboot. I set the power button to hibernate the machine instead of sleep and so that closing the lid will only turn off the screen for me.

That's strange because hibernate mode makes the hard drive shut down and closes all open apps.

sakya (OP)

Re: Sleep problem
« Reply #4 on: November 21, 2016, 09:45:01 pm »
It sounds like you have Hibernate Mode enabled. Hope this helps. :)
I disabled hibernate mode with the command
Code: [Select]
powercfg /h offand all seems ok now!
Many thanks! ;)

Macatron

Re: Sleep problem
« Reply #5 on: November 21, 2016, 10:08:27 pm »
It sounds like you have Hibernate Mode enabled. Hope this helps. :)
I disabled hibernate mode with the command
Code: [Select]
powercfg /h offand all seems ok now!
Many thanks! ;)

Awesome! Glad I could help. :) I've never had a good experience with hibernate mode on any Windows version if that makes you feel any better. :D

CrazyCoder

Re: Sleep problem
« Reply #6 on: February 12, 2017, 10:59:33 am »
I have the same problem, but disabling Hibernate mode didn't help. Any other ideas?

UPDATE: https://www.reddit.com/r/gpdwin/comments/5lv3es/idle_usage_and_sleep_crashes/ seems to help (changing the C-state).
« Last Edit: February 12, 2017, 05:43:42 pm by CrazyCoder »

shinkamui

  • *
  • Posts: 395
Re: Sleep problem
« Reply #7 on: March 03, 2017, 09:55:19 pm »
GOD DAMN AWESOMENESS.  The C-State switch to C6 completely fixed my sleep of death and the random sleep restarts on my unit.  Been using it now for 5 days, and have not yet had a single instance where opening the lid didn't wake the unit, AND return me to what I left on the desktop, apps running and all.  I'm finally at this point pretty happy with my unit barring the crappy mouse mode mapping.  Anyone who has to use hibernation, or is having the sleep of death should try this.  Im not even seeing a major drain of battery in standby mode in comparison to what i was used to when having to power down (hibernation) over the course of 6-8 hours.  Highly recommended.

Faust

  • *
  • Posts: 305
Re: Sleep problem
« Reply #8 on: March 04, 2017, 04:00:56 pm »
GOD DAMN AWESOMENESS.  The C-State switch to C6 completely fixed my sleep of death and the random sleep restarts on my unit.  Been using it now for 5 days, and have not yet had a single instance where opening the lid didn't wake the unit, AND return me to what I left on the desktop, apps running and all.  I'm finally at this point pretty happy with my unit barring the crappy mouse mode mapping.  Anyone who has to use hibernation, or is having the sleep of death should try this.  Im not even seeing a major drain of battery in standby mode in comparison to what i was used to when having to power down (hibernation) over the course of 6-8 hours.  Highly recommended.
I double confirm, thanks Pal.

frikisama

Re: Sleep problem
« Reply #9 on: March 05, 2017, 11:53:46 am »
Do all of you have BOTH settings available in your BIOS? I don't see any possibility to change the package C state under Advanced -> CPU Configuration.

Willburn

Re: Sleep problem
« Reply #10 on: March 05, 2017, 02:27:15 pm »
Do all of you have BOTH settings available in your BIOS? I don't see any possibility to change the package C state under Advanced -> CPU Configuration.

I don't have that one either

Faust

  • *
  • Posts: 305
Re: Sleep problem
« Reply #11 on: March 05, 2017, 05:53:42 pm »
I didn't check where it exactly was but you have two lines, the first is the maximum C-state that you allow, and the second one is the one you want to set.

Maniac

Re: Sleep problem
« Reply #12 on: March 06, 2017, 01:24:24 pm »
Switching to C6 didn't fix mine, I had to simply disable connected standby completely.

Faust

  • *
  • Posts: 305
Re: Sleep problem
« Reply #13 on: March 07, 2017, 04:51:15 pm »
Switching to C6 didn't fix mine, I had to simply disable connected standby completely.
So you cannot turn your device in sleeps mode anymore?

Maniac

Re: Sleep problem
« Reply #14 on: March 08, 2017, 01:54:37 am »
So you cannot turn your device in sleeps mode anymore?

Right, as mentioned in the other thread, I was using hibernate, but I just discovered the 30% CPU usage issue today. Now I will try to research that some more :/

 

Post a new topic