Author Topic: Linux Anyone?  (Read 2597 times)

nevvy

Re: Linux Anyone?
« Reply #15 on: June 14, 2017, 08:10:18 am »
... ever since I've set this dual boot up I've had some insanely  bad crashing under Linux. It seems to be triggered by Gnome's animations, either when I maximize a window, or select an indicator, or open the Activities screen. 

Probably out of the scope of this forum, but has anyone else hit this issue and possibly fixed it? 

...

EDIT: Crashing is fixed! There were a few kernel parameters I needed to add. ...

I'm currently experiencing the same thing (lots of crashes in gnome/mate/unity, almost none in openbox) with dual boot. What kind of kernel parameters have solved this for you?

Piece_Maker

Re: Linux Anyone?
« Reply #16 on: June 14, 2017, 12:58:37 pm »
I swiped them off the Archwiki:

https://wiki.archlinux.org/index.php/Intel_graphics#X_freeze.2Fcrash_with_intel_driver 

which has the two kernel parameters I used as well as further Xorg.conf addons.

nevvy

Re: Linux Anyone?
« Reply #17 on: June 14, 2017, 07:40:02 pm »
I swiped them off the Archwiki:

https://wiki.archlinux.org/index.php/Intel_graphics#X_freeze.2Fcrash_with_intel_driver 

which has the two kernel parameters I used as well as further Xorg.conf addons.
Thanks, the Xorg.conf part seems to have done it for me.

Piece_Maker

Re: Linux Anyone?
« Reply #18 on: June 17, 2017, 01:38:36 am »
Glad it worked! :D Ubuntu Gnome runs amazingly well on this little thing, but gaming performance was shocking. Rocket League was barely playable, while it ran great under Windows. Suppose if you bought it more as a pocket laptop for work stuff you'd be happy but if you're into your games it'd be better to keep Windows (I went with a dual boot, with half the internal memory for each then all my Steam games under Windows on an SD card). 

Sadly my GPD Win is back in China being repaired - turns out those touchscreen issues above were not software-related, and I've tried and tried to get the screen off myself to repair it with zero luck, so I guess I'll not have my Linux-on-a-tiny-device fix for a few weeks now!  >:(

nevvy

Re: Linux Anyone?
« Reply #19 on: June 19, 2017, 08:09:16 am »
After trying out a few distributions I stopped at Xubuntu, so far it seems to work better than Ubuntu Unity and BunsenLabs (Debian with Openbox).

The thing with the latter two is that the rotated display performed very poorly -- the refresh rate was close to 2-3hz. Even something as simple as moving application windows created a LOT of tearing. Gaming performance was poor as well (I used Owlboy as a quick and very lenient benchmark -- on Ubuntu it struggled at ~20fps). At the same time, with non-rotated (vertical) screen everything was fine. On ubuntu the slowdown happened after I disabled 3d acceleration in xorg.conf (Option "DRI" "False") to stop crashes; after that compton was hogging all of the CPU time, probably because it had to go with software compositing.
What happened on BunsenLabs is a mystery -- there I didn't disable 3d acceleration, and I tried to disable to compositor but nothing really helped the performance.

It is not implausible that some compositors don't like rotated screens and gnome's mutter may be at fault for the poor gaming performance (but I have no idea what I'm talking about here). Piece_Maker, you might want to try out other distros to be sure.
UPD: tried Rocket League on xfce, it's pretty slow as well. So it's probably an issue with the port itself.

Bluetooth seems to work with Matan's solution (I had to additionally install pulseaudio-modules-bluetooth to use my bluetooth headphones, but that's not specific to GPD Win).

The only thing not working so far is the microSD reader and I haven't tested the microphone. But everything else seems shiny after what little testing I performed.  :)



UPD Jun 20: nope, not shiny, it's still crashing pretty heavily in games. All games crash the same way: within a couple of minutes of playing the screen freezes and the last 2-3 sec of sound are playing on a loop, -- so that's a problem with the system, not the games.

-- Disabling CPU Turbo Mode in BIOS as Arch wiki suggests had no effect;
-- using kernel option "intel_idle.max_cstate=1" as per this bug had no effect;
-- using xorg option "DRI" "False" to disable 3d acceleration helped -- I was able to play through 20min of Papers Please without crashing, -- but renders any 3d games unplayable, which is not really a tolerable outcome.

Has anyone figured this part out?

UPD: kernel boot option "i915.enable_rc6=0" helped.
« Last Edit: June 21, 2017, 04:31:13 am by nevvy »

 

Post a new topic