Author Topic: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]  (Read 85893 times)

thefifthgiant

  • *
  • Posts: 107
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #360 on: February 03, 2016, 01:39:39 am »
Would it really be that much of a problem performance-wise? I've never run into an issue with games I've played (though he most demanding ones I play are probably Starfox 1&2) If we're talking a drop from 60 fps on most games down to 30 or so, I think most people would be able to tolerate it, providing that emulation of the new chip could be turned off on games that don't need it. If i remember correctly, picodrive had several options on what chips/hardware to emulate for sound.

I'm assuming the bigger issue is the amount of effort it would take to implement? Of course i'm not a dev by any means so I don't really have any idea.

Qubits

  • *
  • Posts: 143
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #361 on: May 26, 2016, 06:37:40 am »
Is it possible to select the clock speed (NTSC or PAL) for Europe or USA / Japanese roms ? And if not is it on NTSC by default or does it automatically detect the clock speed of the rom ?
« Last Edit: May 26, 2016, 07:10:15 am by Qubits »

Aeter

  • *
  • Posts: 285
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #362 on: May 26, 2016, 01:41:01 pm »
Is it possible to select the clock speed (NTSC or PAL) for Europe or USA / Japanese roms ? And if not is it on NTSC by default or does it automatically detect the clock speed of the rom ?
I believe you can change this in the settings. There should be a PAL/NTSC setting in there.
~cucullus non facit monachum~

Qubits

  • *
  • Posts: 143
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #363 on: May 26, 2016, 01:45:50 pm »
Is it possible to select the clock speed (NTSC or PAL) for Europe or USA / Japanese roms ? And if not is it on NTSC by default or does it automatically detect the clock speed of the rom ?
I believe you can change this in the settings. There should be a PAL/NTSC setting in there.

No but after talking with the developpers, they've explained me that it detects the rom speed automatically by using a " magical " code in the ROM header.

Aeter

  • *
  • Posts: 285
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #364 on: May 26, 2016, 02:15:19 pm »
Is it possible to select the clock speed (NTSC or PAL) for Europe or USA / Japanese roms ? And if not is it on NTSC by default or does it automatically detect the clock speed of the rom ?
I believe you can change this in the settings. There should be a PAL/NTSC setting in there.

No but after talking with the developpers, they've explained me that it detects the rom speed automatically by using a " magical " code in the ROM header.
Oh okay, I do remember some PAL/NTSC setting in there somewhere though, must be unrelated then.
~cucullus non facit monachum~

Qubits

  • *
  • Posts: 143
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #365 on: May 27, 2016, 08:42:39 pm »
I've been playing quite a lot of snes games today, everything runs rather smoothly except for : " Jikkyou Oshaberi Parodius (Japan) ", which has massives slowdowns, even if you set " video quality first " and change the frameskip settings.

Aeter

  • *
  • Posts: 285
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #366 on: May 28, 2016, 01:30:49 pm »
I've been playing quite a lot of snes games today, everything runs rather smoothly except for : " Jikkyou Oshaberi Parodius (Japan) ", which has massives slowdowns, even if you set " video quality first " and change the frameskip settings.
Aren't there English versions of Parodius or is this a JP only release?
I prefer the original NES version anyway, with the epic 8-bit music, oh the memories of days gone by.
~cucullus non facit monachum~

Qubits

  • *
  • Posts: 143
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #367 on: May 28, 2016, 01:37:28 pm »
I've been playing quite a lot of snes games today, everything runs rather smoothly except for : " Jikkyou Oshaberi Parodius (Japan) ", which has massives slowdowns, even if you set " video quality first " and change the frameskip settings.
Aren't there English versions of Parodius or is this a JP only release?
I prefer the original NES version anyway, with the epic 8-bit music, oh the memories of days gone by.

This Snes version is much better. There is no US release, unfortunately.

Aeter

  • *
  • Posts: 285
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #368 on: May 28, 2016, 01:44:10 pm »
I've been playing quite a lot of snes games today, everything runs rather smoothly except for : " Jikkyou Oshaberi Parodius (Japan) ", which has massives slowdowns, even if you set " video quality first " and change the frameskip settings.
Aren't there English versions of Parodius or is this a JP only release?
I prefer the original NES version anyway, with the epic 8-bit music, oh the memories of days gone by.

This Snes version is much better. There is no US release, unfortunately.
But play the NES EU version on my actual NES for nostalgic reasons, can't beat my nostalgia as I never had a SNES.
Perhaps the arcade Sexy Parodius is more to your liking :P. NES Version is in English by the way. 
~cucullus non facit monachum~

TimeDevouncer

  • *
  • Posts: 231
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #369 on: September 14, 2016, 08:40:00 am »
Any way to fix hi-res texts like Romancing Saga 3 menus?

I try with the IPU scaling and no luck :(
Look behind you! A three-headed monkey!

gameblabla

  • *
  • Posts: 463
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #370 on: September 14, 2016, 02:07:08 pm »
Any way to fix hi-res texts like Romancing Saga 3 menus?
I try with the IPU scaling and no luck :(
IPU scaling isn't going to make a difference here.
He may have disabled the hi-resolution or Snes9X 1.43 does not emulate this game properly.
If the issue is the later, then there might be no solution... (as the later SnesEx 1.5x is too demanding for the GCW0

TimeDevouncer

  • *
  • Posts: 231
Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #371 on: September 14, 2016, 10:27:05 pm »
Any way to fix hi-res texts like Romancing Saga 3 menus?
I try with the IPU scaling and no luck :(
IPU scaling isn't going to make a difference here.
He may have disabled the hi-resolution or Snes9X 1.43 does not emulate this game properly.
If the issue is the later, then there might be no solution... (as the later SnesEx 1.5x is too demanding for the GCW0

Ouch! Ok, thanks ;D
Look behind you! A three-headed monkey!

madligame

Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #372 on: December 10, 2016, 09:56:27 am »
Hi forum, which key for quick save state and load state? I tried L+R left /right not working :(

Thanks

nightshade

Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #373 on: December 10, 2016, 10:43:21 pm »
Hi forum, which key for quick save state and load state? I tried L+R left /right not working :(

Thanks
you cant ... that feature has been disabled by snes9x ....... so they cant do it anymore
« Last Edit: December 10, 2016, 10:46:01 pm by nightshade »

SNES72

Re: PocketSNES based on Snes9x 1.43-dev [2014-08-24 update]
« Reply #374 on: January 05, 2017, 12:37:22 am »
The link to the opk seems to be broken, is there another link where I can install the SNES emulator?

 

Post a new topic
Post a new topic