Author Topic: gngeo port (neogeo emulator)  (Read 33341 times)

Scoobysnaxx

  • *
  • Posts: 128
Re: gngeo port (neogeo emulator)
« Reply #30 on: September 27, 2013, 03:25:18 am »
Finally got around to trying this. Everything i throw at it runs beautifully. Thank you for this wonderful port. I very much enjoy the front end too!  ;D

I too was getting errors about the romset being too old (even after having successfully running them a first time). Once I moved everything to the home directory the problem disappeared. Thank you for the suggestion GhostWarrior

goldenegg

Re: gngeo port (neogeo emulator)
« Reply #31 on: September 27, 2013, 06:57:12 am »
I'm having trouble with this one.   Every time I try to load a game, the emulator crashes.   I'm using the same rom set that I use on the Pandora, which checks out fine with the DAT.  I'm running the emulator from an external card.

Any ideas?

pepone (OP)

Re: gngeo port (neogeo emulator)
« Reply #32 on: September 27, 2013, 09:32:06 am »
Strange.
Can you enable output logging in gmenu, and copy/paste the output here?

Atlantis_Risen

  • **
  • Posts: 556
Re: gngeo port (neogeo emulator)
« Reply #33 on: September 27, 2013, 01:20:10 pm »
Finally got around to trying this. Everything i throw at it runs beautifully. Thank you for this wonderful port. I very much enjoy the front end too!  ;D

I too was getting errors about the romset being too old (even after having successfully running them a first time). Once I moved everything to the home directory the problem disappeared. Thank you for the suggestion GhostWarrior

Do you play Neo Turfmasters?  I get a weird bug where every hit is 1000 times too powerful and the ball flies into orbit with every shot.  Adjusting various settings, like raster effects, hasn't helped.  It's my favorite Neo Geo game too. :(

hi-ban

  • **
  • Posts: 821
Re: gngeo port (neogeo emulator)
« Reply #34 on: September 27, 2013, 02:35:28 pm »
Do you play Neo Turfmasters?  I get a weird bug where every hit is 1000 times too powerful and the ball flies into orbit with every shot.  Adjusting various settings, like raster effects, hasn't helped.  It's my favorite Neo Geo game too. :(

I also get this bug. It does not happen always, though.

pepone (OP)

Re: gngeo port (neogeo emulator)
« Reply #35 on: September 27, 2013, 04:48:59 pm »
I've never heard of this bug, so congrats to find a new one :) Looks like a integer over/underflow or something like that. I'll look into It.

Atlantis_Risen

  • **
  • Posts: 556
Re: gngeo port (neogeo emulator)
« Reply #36 on: September 27, 2013, 06:07:09 pm »
I've never heard of this bug, so congrats to find a new one :) Looks like a integer over/underflow or something like that. I'll look into It.

Thanks! :)  I had the same bug using neodroid for android.

pepone (OP)

Re: gngeo port (neogeo emulator)
« Reply #37 on: September 27, 2013, 07:38:13 pm »
it's a port of gngeo, so...
« Last Edit: September 27, 2013, 07:42:34 pm by pepone »

Atlantis_Risen

  • **
  • Posts: 556
Re: gngeo port (neogeo emulator)
« Reply #38 on: September 27, 2013, 08:14:01 pm »
I'm just saying it isn't a problem that's exclusive to gngeo.

goldenegg

Re: gngeo port (neogeo emulator)
« Reply #39 on: September 28, 2013, 05:09:26 am »
Strange.
Can you enable output logging in gmenu, and copy/paste the output here?

Sure.  Where will the log be output?  Is it on the internet SD or with the app on the external?

pcercuei

  • ***
  • Posts: 1388
    • GitHub
Re: gngeo port (neogeo emulator)
« Reply #40 on: September 28, 2013, 08:01:13 am »
home/.gmenu2x/gmenu2x.log

pepone (OP)

Re: gngeo port (neogeo emulator)
« Reply #41 on: September 28, 2013, 08:23:40 am »
I'm just saying it isn't a problem that's exclusive to gngeo.
Sorry I was not clear. What I was saying is that neodroid is a port of gngeo, so I guess the bug is indeed exclusive to gngeo :)
Did you used the asm core with neodroid? If yes, then it means that the bug in not in the cpu core

goldenegg

Re: gngeo port (neogeo emulator)
« Reply #42 on: September 29, 2013, 01:53:50 am »
WTH?  I enable logging to capture the error and it no longer crashes  :P

Honestly, I tried the emulator multiple times and it never worked for me.  I have no idea why it would suddenly start working.  Maybe it's a combination of other apps I was running prior to the emulator in the past.

I'll keep my eye on it and will provide logs if the problem happens again.

Fei

  • *
  • Posts: 17
    • Retre-gaming Connexion
Re: gngeo port (neogeo emulator)
« Reply #43 on: October 05, 2013, 05:50:31 pm »
Hey merci pepone pour ce portage :)
Thanks pepone for the port !

I just test it with 2-3 games and it works really fine :D
Do you plan to add joystick support (if not already done) ?

pepone (OP)

Re: gngeo port (neogeo emulator)
« Reply #44 on: October 06, 2013, 04:29:45 pm »
Thanks :)
adding joystick support should be easy. I just have to modify the configuration file.
I just have to check how the joystick show up in SDL.

 

Post a new topic
Post a new topic