Author Topic: GCW Zero emulation in QEMU  (Read 2959 times)

dmitry_smagin (OP)

  • *
  • Posts: 395
GCW Zero emulation in QEMU
« on: May 14, 2015, 07:31:06 pm »
Now you can run GCW Zero's software right on your PC using QEMU!



Instructions and video tutorials are in the news: http://www.gcw-zero.com/news.php?id=13
Direct download link: http://www.gcw-zero.com/files/gcw0-qemu.zip

Discuss, report bugs etc here, please.
GCW-Zero prototype, Dingoo a320, Ritmix rzx-50, Dingoo a380, Xperia Play

David Knight

Re: GCW Zero emulation in QEMU
« Reply #1 on: May 14, 2015, 09:51:07 pm »
Perfect, thanks so much for this :)

Aeter

  • *
  • Posts: 277
Re: GCW Zero emulation in QEMU
« Reply #2 on: May 16, 2015, 12:17:55 pm »
This is great for developers without a console like Ziz and others perhaps. Might also draw more programmers because they can actually test things themselves too, which makes them less dependent on others.

Great stuff dmitry.
~cucullus non facit monachum~

Vato

  • *
  • Posts: 71
Re: GCW Zero emulation in QEMU
« Reply #3 on: May 28, 2015, 12:47:59 am »
this is pretty cool. just got the basic package running on my aging winXP PC.
works nice with the OP package, but i must be doing something wrong (thinkin i got too big of a folder full of .opk's) cuz i havent been able to add my stuff successfully.

what id really like (but havent fingered out how to yet) is to get this going on my shield and ouya via teh android qemu port/limbo.

kaio

  • *
  • Posts: 209
    • All about GCW-Zero on Russian + Repo
Re: GCW Zero emulation in QEMU
« Reply #4 on: June 12, 2015, 12:38:38 pm »
Hello. I try to run under linux, but have an error.
run-gcw0.sh: line 15: qemu-system-mipsel: command not found
what i do wrong?
qemu is installed
my os - Slackware 14.1

GCW-Zero | JXD S602

dmitry_smagin (OP)

  • *
  • Posts: 395
Re: GCW Zero emulation in QEMU
« Reply #5 on: June 12, 2015, 01:11:49 pm »
Hello. I try to run under linux, but have an error.
run-gcw0.sh: line 15: qemu-system-mipsel: command not found
what i do wrong?
qemu is installed
my os - Slackware 14.1
Probably, your qemu doesn't have mipsel target compiled or is installed to different path.
Check 'ls /usr/bin/qemu*' command. Normal output should be:
Quote
dmitry@dmitry-K52Dr:~$ ls /usr/bin/qemu*
/usr/bin/qemu-aarch64       /usr/bin/qemu-mipsn32         /usr/bin/qemu-system-alpha         /usr/bin/qemu-system-ppc64
/usr/bin/qemu-alpha         /usr/bin/qemu-mipsn32el       /usr/bin/qemu-system-arm           /usr/bin/qemu-system-ppc64le
/usr/bin/qemu-arm           /usr/bin/qemu-nbd             /usr/bin/qemu-system-cris          /usr/bin/qemu-system-ppcemb
/usr/bin/qemu-armeb         /usr/bin/qemu-or32            /usr/bin/qemu-system-i386          /usr/bin/qemu-system-s390x
/usr/bin/qemu-cris          /usr/bin/qemu-ppc             /usr/bin/qemu-system-lm32          /usr/bin/qemu-system-sh4
/usr/bin/qemu-i386          /usr/bin/qemu-ppc64           /usr/bin/qemu-system-m68k          /usr/bin/qemu-system-sh4eb
/usr/bin/qemu-img           /usr/bin/qemu-ppc64abi32      /usr/bin/qemu-system-microblaze    /usr/bin/qemu-system-sparc
/usr/bin/qemu-io            /usr/bin/qemu-ppc64le         /usr/bin/qemu-system-microblazeel  /usr/bin/qemu-system-sparc64
/usr/bin/qemu-m68k          /usr/bin/qemu-s390x           /usr/bin/qemu-system-mips          /usr/bin/qemu-system-tricore
/usr/bin/qemu-microblaze    /usr/bin/qemu-sh4             /usr/bin/qemu-system-mips64        /usr/bin/qemu-system-unicore32
/usr/bin/qemu-microblazeel  /usr/bin/qemu-sh4eb           /usr/bin/qemu-system-mips64el      /usr/bin/qemu-system-x86_64
/usr/bin/qemu-mips          /usr/bin/qemu-sparc           /usr/bin/qemu-system-mipsel        /usr/bin/qemu-system-xtensa
/usr/bin/qemu-mips64        /usr/bin/qemu-sparc32plus     /usr/bin/qemu-system-moxie         /usr/bin/qemu-system-xtensaeb
/usr/bin/qemu-mips64el      /usr/bin/qemu-sparc64         /usr/bin/qemu-system-or32          /usr/bin/qemu-unicore32
/usr/bin/qemu-mipsel        /usr/bin/qemu-system-aarch64  /usr/bin/qemu-system-ppc           /usr/bin/qemu-x86_64


Otherwise check this link how to build qemu yourself: http://slackbuilds.org/repository/14.1/system/qemu/
GCW-Zero prototype, Dingoo a320, Ritmix rzx-50, Dingoo a380, Xperia Play

dmitry_smagin (OP)

  • *
  • Posts: 395
Re: GCW Zero emulation in QEMU
« Reply #6 on: February 12, 2016, 01:09:04 pm »
I recently discovered that rootfs used in gcw0-qemu package lacks libmikmod.

Fixed package: http://www.gcw-zero.com/files/gcw0-qemu_update.zip
« Last Edit: February 12, 2016, 04:34:36 pm by dmitry_smagin »
GCW-Zero prototype, Dingoo a320, Ritmix rzx-50, Dingoo a380, Xperia Play