Author Topic: Opendingux-can't access nand?!...  (Read 1668 times)

electrozone (OP)

Opendingux-can't access nand?!...
« on: June 17, 2012, 06:26:47 pm »
I've just downloaded opendingux, installed it and it works. Howerver, i can not access nand. There is just one folder in the "media"  folder(mmcblk0p1) which is the memory card. I guess there should be two folders.
I've had this problem before when i tried the beta version of OD, so i waited for the official realease but this one seems to have the same problem.  >:( It is so annoying because most of my roms are on the nand memory.
I would really appreciate if u could help me.  ;D If you need extra information about my dingoo or my firmware just ask.

***UPDATE: I changed my firmware and now i find that folder and i can access it but just throught application like dingux commander or psx.However,using the regular browser (the one used by snes9x or gpsp or Explorer), when  i try to acces that folder the image goes black and then quits the browser. Is this normal?
« Last Edit: June 17, 2012, 07:40:35 pm by electrozone »
The following statement is true: The first statement is false.

zear

  • * Moderator
  • Posts: 2378
Re: Opendingux-can't access nand?!...
« Reply #1 on: June 17, 2012, 09:03:09 pm »
gmenu2x has a problem handling filenames with accents in them (ie. chinese fonts). Folders containing such characters will crash and restart gmenu2x.

mth

  • *
  • Posts: 297
Re: Opendingux-can't access nand?!...
« Reply #2 on: June 17, 2012, 10:38:50 pm »
The problem is that the data partitions are actually on different NAND blocks on electrozone's Dingoo compared to the vast majority of Dingoos out there. And currently we have a static NAND partitioning in the OD kernel. I don't know yet if it is feasible to autodetect the partition boundaries instead of hardcoding them.
(edit: that was the original problem, the re-flashing probably cured it)

spn-x

  • *
  • Posts: 109
Re: Opendingux-can't access nand?!...
« Reply #3 on: September 05, 2014, 07:44:40 pm »
I have to dig this thread up :(

I also got that problem now... Before I was always able to get to the internal memory with gmenu2x but all of a sudden it doesn't show it.. I dont really need it but I just wanted to know if this is a sign that something is destroyed in the internal storage and if I have to be worried.

My Dingoo : Dingux // dmenu 0.3 ; gmenu2x // Native : FW 1.2
                    Joystick Mod