Author Topic: Themes not working after 1.22 firmware update  (Read 6285 times)

Mushroom

  • Guest
Themes not working after 1.22 firmware update
« on: February 11, 2010, 09:49:19 am »
Hey, noticed there was a new version of the official firmware (1.22) so I installed it.  Device comes back on and it's back to that default Engrish theme, which didn't surprise me.  So I drop in the Windows 7 Transference theme and... uh, still the defaults.  Copied /system/res/a to /b /c and /d and it's still the default.  On a lark I even deleted the whole /res folder, and it still comes up with the default theme (I was expecting an error since the files are missing).  I checked the HXF file with the editing tool and it does point to the /system/res/* folders, so it doesn't appear to be reading the files from a different location.

So am I missing a step or did something get disabled?  I had the W7T theme working just fine under the tweaked-1.20 all the smart kids are using an hour ago.  Halp?

omgmog

  • * Administrator
  • Doesn't sleep.
  • Posts: 707
    • omgmog.net
Re: Themes not working after 1.22 firmware update
« Reply #1 on: February 11, 2010, 10:04:54 am »
Default firmware isn't patched to allow custom themes.

you will need to install a custom/hacked firmware that has custom themes enabled, then ensure you have a /SYSTEM/directory on the Dingoo flash

TheMushroom

  • Guest
Re: Themes not working after 1.22 firmware update
« Reply #2 on: February 12, 2010, 05:40:40 am »
Drat, that was my next thought:  "did theme switching come stock or not?"  Hopefully someone will beat on 1.22 then so we can de-ugly it again.

eule

  • * Former Staff
  • e
  • Posts: 889
Re: Themes not working after 1.22 firmware update
« Reply #3 on: February 12, 2010, 11:43:48 am »
Here is 1.22 patched for themes:
http://uploaded.to/file/cc63at
NEVER forget to copy the system folder along with the A320.hxf to your Dingoo or itīll brick!!!
 :)
ps: for more modifications use hxf tool: http://dl.openhandhelds.org/cgi-bin/dingoo.cgi?0,0,0,0,116,45
« Last Edit: February 12, 2010, 11:45:41 am by eule »

bloodgnome

Re: Themes not working after 1.22 firmware update
« Reply #4 on: February 17, 2010, 03:00:04 pm »
So whats new with 1.22 ? New goodies ? Bugfixes ? Faster ?

Or is it just another lanuage-update ?

TheMushroom

  • Guest
Re: Themes not working after 1.22 firmware update
« Reply #5 on: February 19, 2010, 09:57:22 pm »
You are my hero, eule...  Didn't notice the "patch to add themes" button in the HXF Editor.  LOL!

Now to:
a) modify the boot screen - done
b) change the /a folder to my own theme - done
c) run Date Patcher so device will install new firmware - done and pretty!
d) change the menu text because "3D game" and "Interesting game" are kinda stupid titles  ;)
____ - Okay, now the HXF contains proper English.

However, since I already used the date patcher on the HXF it's saying "same firmware version"; won't update with the changes! :(  
I did set the computer's clock ahead a day then try a patch but that didn't fix.  Suggestions?  Some line to modify in the HXF?

[minutes later] Downgrade to 1.20-dof HXF then reinstall of modded 1.22 HXF fixed issue.   ::)  Happy happy.
« Last Edit: February 20, 2010, 12:11:40 am by TheMushroom »

hayneken

Re: Themes not working after 1.22 firmware update
« Reply #6 on: March 27, 2012, 08:15:06 pm »
Here is 1.22 patched for themes:
http://uploaded.to/file/cc63at
NEVER forget to copy the system folder along with the A320.hxf to your Dingoo or itīll brick!!!
 :)
ps: for more modifications use hxf tool: http://dl.openhandhelds.org/cgi-bin/dingoo.cgi?0,0,0,0,116,45

links are broken, plz renew
Dingoo a320 - ILI9338 user

 

Post a new topic